Peter Broekman asked 7 months ago

Abu, On bulk-edit I have a dropdown that gets two lines extra: 1) empty row and 2) – empty –  next to Yes and No I like to. I set the editrules to required. I think I like the first empty space. If you add submit too fast it will just let everything the same. I also like that if you do not change other fields they stay the same as wqell even if you change one field. I do NOT  like the – empty – it will populate my records with null value which I do not allow, but is somehow allowed (recaorsd are updated to null). Kind regards   Peter Broekman

3 Answers
Abu Ghufran Staff answered 7 months ago


The -Empty- options comes when you have allowed blank selection in dropdown. See :; options in list.

$col[“editoptions”] = array(“value”=>”:;100:One Hundred;200:Two Hundred;300:Three Hundred”);

If you remove that blank option,

$col[“editoptions”] = array(“value”=>”100:One Hundred;200:Two Hundred;300:Three Hundred”);

then there will be no -Empty- in bulk edit as well.

Abu Ghufran - Dev Team
Grid 4 PHP Framework
Peter Broekman answered 7 months ago

This are my editoptions – so apparently this does not work as expected? In the normal edit I do not have this problem

$colb[“editoptions”] = array(“value”=>”Yes:Yes;No:No”);

Abu Ghufran Staff answered 7 months ago

Can you confirm this issue on demos/editing/bulkedit.php demo? The above code is from this demo.

Please share complete column configuration so i can regenerate it.

Abu Ghufran - Dev Team
Grid 4 PHP Framework
Your Answer

20 + 10 =

Login with your Social Id:

OR, enter

Attach code here and paste link in question.
Attach screenshot here and paste link in question.

How useful was this discussion?

Click on a star to rate it!

Average rating 0 / 5. Vote count: 0

No votes so far! Be the first to rate it.

We are sorry that this post was not useful for you!

Let us improve this post!

Tell us how we can improve this post?