You need to enable php extension 'mysql' first.

QuestionsYou need to enable php extension 'mysql' first.
Hamaguchi asked 2 weeks ago

To whom it may concern

I did “Installing Demos Manually” by following the steps below.
After executing (4), “You need to enable php extension’mysql’ first.” Will be displayed on the demo screen.
What should I do to deal with this message?

1) Execute “database.sql” on a Mysql Database. It will create ‘griddemo’ database.
2) Place all files in a directory on the web server. e.g. “…/www/gridphp/”
3) Rename config.sample.php to config.php, and update database config. e.g.
define(“PHPGRID_DBTYPE”,”mysqli”);
define(“PHPGRID_DBHOST”,”localhost”);
define(“PHPGRID_DBUSER”,”root”);
define(“PHPGRID_DBPASS”,”XXXXXXXX”);
define(“PHPGRID_DBNAME”,”griddemo”);
// It will work in normal cases, unless you change lib folder location
define(“PHPGRID_LIBPATH”,dirname(__FILE__).DIRECTORY_SEPARATOR.”lib”.DIRECTORY_SEPARATOR);
4) Run the product demos in browser. e.g. http://localhost/gridphp/index.php

Best Regards,

Hamaguchi

1 Answers
Abu Ghufran Staff answered 1 week ago

Hello,

Message is obvious that your php setup does not have mysql enabled. If you install one of the packages like xampp OR wamp OR uniform server, It comes with php + mysql packaged.

https://www.uniformserver.com/

https://www.apachefriends.org/

https://www.wampserver.com/en/

_________________________
Abu Ghufran - Dev Team
Grid 4 PHP Framework
 
Your Answer

3 + 19 =

Login with your Social Id:

OR, enter

Attach code here and paste link in question.
Attach screenshot here and paste link in question.



How useful was this discussion?

Click on a star to rate it!

Average rating 0 / 5. Vote count: 0

No votes so far! Be the first to rate it.

We are sorry that this post was not useful for you!

Let us improve this post!

Tell us how we can improve this post?